import Foundation
let pattern = #"\[id(\d{1,20})\|(.*?)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[id215554550|Евгений Маркин]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="/users/$1">$2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)