import re
regex = re.compile(r"\[id(\d{1,20})\|(.*?)\]")
test_str = "[id215554550|Евгений Маркин]"
subst = "<a href=\"/users/$1\">$2</a>"
result = regex.sub(subst, test_str)
if result:
print(result)