// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[id(\d{1,20})\|(.*?)\]").unwrap();
let string = "[id215554550|Евгений Маркин]";
let substitution = "<a href=\"/users/$1\">$2</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}