# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<span>(.*?)<\\/span>//g;t' <<< "</span><span>wanna-string</span></a>"