import Foundation
let pattern = #"<span>(.*?)<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"</span><span>wanna-string</span></a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)