#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<span>(.*?)<\/span>"
Local $sString = "</span><span>wanna-string</span></a>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)