$re = '/<span>(.*?)<\/span>/';
$str = '</span><span>wanna-string</span></a>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;