use strict;
my $str = '</span><span>wanna-string</span></a>';
my $regex = qr/<span>(.*?)<\/span>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";