package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<span>(.*?)<\/span>`)
var str = `</span><span>wanna-string</span></a>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}