const regex = /<span>(.*?)<\/span>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span>(.*?)<\\\/span>', 'g')
const str = `</span><span>wanna-string</span></a>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);