using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span>(.*?)<\/span>";
string substitution = @"";
string input = @"</span><span>wanna-string</span></a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}