# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/some(([A-Z][a-z]*)+)/\1/gm;t' <<< "var someVarOne, someVarTwo, someVarThree, someOtherVar, someVar, someThing;
var some;"