const regex = /some(([A-Z][a-z]*)+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('some(([A-Z][a-z]*)+)', 'gm')
const str = `var someVarOne, someVarTwo, someVarThree, someOtherVar, someVar, someThing;
var some;`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);