#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)some(([A-Z][a-z]*)+)"
Local $sString = "var someVarOne, someVarTwo, someVarThree, someOtherVar, someVar, someThing;" & @CRLF & _
"" & @CRLF & _
"var some;"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)