import Foundation
let pattern = #"some(([A-Z][a-z]*)+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
var someVarOne, someVarTwo, someVarThree, someOtherVar, someVar, someThing;
var some;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)