using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"some(([A-Z][a-z]*)+)";
string substitution = @"\1";
string input = @"var someVarOne, someVarTwo, someVarThree, someOtherVar, someVar, someThing;
var some;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}