re = /some(([A-Z][a-z]*)+)/m
str = 'var someVarOne, someVarTwo, someVarThree, someOtherVar, someVar, someThing;
var some;'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result