package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)some(([A-Z][a-z]*)+)`)
var str = `var someVarOne, someVarTwo, someVarThree, someOtherVar, someVar, someThing;
var some;`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}