use strict;
my $str = 'var someVarOne, someVarTwo, someVarThree, someOtherVar, someVar, someThing;
var some;';
my $regex = qr/some(([A-Z][a-z]*)+)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";