$re = '/some(([A-Z][a-z]*)+)/m';
$str = 'var someVarOne, someVarTwo, someVarThree, someOtherVar, someVar, someThing;
var some;';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;