using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""\""\""(.*?)\""\""\""|'''(.*?)'''|""(.*?)""|'(.*?)'";
string input = @"#%%sql
""double quoted string""
q = """"
select
name, breed, sum(weight) over (partition by breed order by name) as running_total_weight
from cats
order by breed, name
""""
'single quoted string'
foo
bar
""double quoted string""
xyz
'''
single
quoted
multiline
text
'''
end
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}