re = /\"\"\"(.*?)\"\"\"|'''(.*?)'''|"(.*?)"|'(.*?)'/
str = '#%%sql
"double quoted string"
q = """
select
name, breed, sum(weight) over (partition by breed order by name) as running_total_weight
from cats
order by breed, name
"""
\'single quoted string\'
foo
bar
"double quoted string"
xyz
\'\'\'
single
quoted
multiline
text
\'\'\'
end
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end