$re = '/\"\"\"(.*?)\"\"\"|\'\'\'(.*?)\'\'\'|"(.*?)"|\'(.*?)\'/s';
$str = '#%%sql
"double quoted string"
q = """
select
name, breed, sum(weight) over (partition by breed order by name) as running_total_weight
from cats
order by breed, name
"""
\'single quoted string\'
foo
bar
"double quoted string"
xyz
\'\'\'
single
quoted
multiline
text
\'\'\'
end
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);