import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"\\\"\\\"(.*?)\\\"\\\"\\\"|'''(.*?)'''|\"(.*?)\"|'(.*?)'";
final String string = "#%%sql\n"
+ "\"double quoted string\"\n\n"
+ "q = \"\"\"\n"
+ "select\n"
+ "name, breed, sum(weight) over (partition by breed order by name) as running_total_weight\n"
+ "from cats\n"
+ "order by breed, name\n"
+ "\"\"\"\n\n"
+ "'single quoted string'\n"
+ "foo\n"
+ "bar\n"
+ "\"double quoted string\"\n"
+ "xyz\n"
+ "'''\n"
+ "single\n"
+ "quoted\n"
+ "multiline\n"
+ "text\n"
+ "'''\n"
+ "end\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}