package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\"\"\"(.*?)\"\"\"|'''(.*?)'''|"(.*?)"|'(.*?)'`)
var str = `#%%sql
"double quoted string"
q = """
select
name, breed, sum(weight) over (partition by breed order by name) as running_total_weight
from cats
order by breed, name
"""
'single quoted string'
foo
bar
"double quoted string"
xyz
'''
single
quoted
multiline
text
'''
end
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}