// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)\"\"\"(.*?)\"\"\"|'''(.*?)'''|"(.*?)"|'(.*?)'"#).unwrap();
let string = "#%%sql
\"double quoted string\"
q = \"\"\"
select
name, breed, sum(weight) over (partition by breed order by name) as running_total_weight
from cats
order by breed, name
\"\"\"
'single quoted string'
foo
bar
\"double quoted string\"
xyz
'''
single
quoted
multiline
text
'''
end
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}