const regex = new RegExp('\\"\\"\\"(.*?)\\"\\"\\"|\\'\\'\\'(.*?)\\'\\'\\'|"(.*?)"|\\'(.*?)\\'', 'sg')
const str = `#%%sql
"double quoted string"
q = """
select
name, breed, sum(weight) over (partition by breed order by name) as running_total_weight
from cats
order by breed, name
"""
'single quoted string'
foo
bar
"double quoted string"
xyz
'''
single
quoted
multiline
text
'''
end
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}