# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)/$1$2$3$4$5$6$7/gm;t' <<< " static public void main(String[] args)"