use strict;
my $str = ' static public void main(String[] args)';
my $regex = qr/(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)/mp;
my $subst = '$1$2$3$4$5$6$7';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";