const regex = /(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)', 'gm')
const str = ` static public void main(String[] args)`;
const subst = `$1$2$3$4$5$6$7`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);