// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)").unwrap();
let string = " static public void main(String[] args)";
let substitution = "$1$2$3$4$5$6$7";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}