import Foundation
let pattern = #"(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" static public void main(String[] args)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4$5$6$7"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)