re = /(public|protected|private)|(abstract|static)|(final)|(volatile)|(synchronized)|(native)|(strictfp)/m
str = ' static public void main(String[] args)'
subst = '$1$2$3$4$5$6$7'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result