# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/New/<span style="color:yellow;">New<\/span>/mg;t' <<< "New things are New
Old is the New Old
"