re = /New/m
str = 'New things are New
Old is the New Old
'
subst = '<span style="color:yellow;">New</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result