using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"New";
string substitution = @"<span style=""color:yellow;"">New</span>";
string input = @"New things are New
Old is the New Old
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}