use strict;
my $str = 'New things are New
Old is the New Old
';
my $regex = qr/New/mp;
my $subst = '<span style="color:yellow;">New</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";