import Foundation
let pattern = #"New"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
New things are New
Old is the New Old
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span style="color:yellow;">New</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)