// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)New").unwrap();
let string = "New things are New
Old is the New Old
";
let substitution = "<span style=\"color:yellow;\">New</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}