const regex = /New/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('New', 'mg')
const str = `New things are New
Old is the New Old
`;
const subst = `<span style="color:yellow;">New</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);