use strict;
my $str = '565593 6551509,594843 6550759,608343 6525259,558843 6512509,556593 6524509';
my $regex = qr/,/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";