using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\\~]+'";
string substitution = @"'";
string input = @"//window[2]//header[@id=\'top\']/div[1]//a[1]
//window[2]//header[@id=\\'top\\']/div[1]//a[1]
//window[2]//header[@id=\\\'top\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\'top\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\'top\\\\\']/div[1]//a[1]
(OR)
//window[2]//header[@id=~~~~~'top~~~~~']/div[1]//a[1]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}