package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\\~]+'`)
var str = `//window[2]//header[@id=\'top\']/div[1]//a[1]
//window[2]//header[@id=\\'top\\']/div[1]//a[1]
//window[2]//header[@id=\\\'top\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\'top\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\'top\\\\\']/div[1]//a[1]
(OR)
//window[2]//header[@id=~~~~~'top~~~~~']/div[1]//a[1]`
var substitution = "'"
fmt.Println(re.ReplaceAllString(str, substitution))
}