import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\\\~]+'";
final String string = "//window[2]//header[@id=\\'top\\']/div[1]//a[1]\n"
+ "//window[2]//header[@id=\\\\'top\\\\']/div[1]//a[1]\n"
+ "//window[2]//header[@id=\\\\\\'top\\\\\\']/div[1]//a[1]\n"
+ "//window[2]//header[@id=\\\\\\\\'top\\\\\\\\']/div[1]//a[1]\n"
+ "//window[2]//header[@id=\\\\\\\\\\'top\\\\\\\\\\']/div[1]//a[1]\n\n"
+ "(OR)\n\n"
+ "//window[2]//header[@id=~~~~~'top~~~~~']/div[1]//a[1]";
final String subst = "'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}