// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\\~]+'").unwrap();
let string = "//window[2]//header[@id=\\'top\\']/div[1]//a[1]
//window[2]//header[@id=\\\\'top\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\'top\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\'top\\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\\\'top\\\\\\\\\\']/div[1]//a[1]
(OR)
//window[2]//header[@id=~~~~~'top~~~~~']/div[1]//a[1]";
let substitution = "'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}