re = /[\\~]+'/
str = '//window[2]//header[@id=\\\'top\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\'top\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\'top\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\\'top\\\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\\\\'top\\\\\\\\\\\']/div[1]//a[1]
(OR)
//window[2]//header[@id=~~~~~\'top~~~~~\']/div[1]//a[1]'
subst = '\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result