import re
regex = re.compile(r"[\\~]+'")
test_str = ("//window[2]//header[@id=\\'top\\']/div[1]//a[1]\n"
"//window[2]//header[@id=\\\\'top\\\\']/div[1]//a[1]\n"
"//window[2]//header[@id=\\\\\\'top\\\\\\']/div[1]//a[1]\n"
"//window[2]//header[@id=\\\\\\\\'top\\\\\\\\']/div[1]//a[1]\n"
"//window[2]//header[@id=\\\\\\\\\\'top\\\\\\\\\\']/div[1]//a[1]\n\n"
"(OR)\n\n"
"//window[2]//header[@id=~~~~~'top~~~~~']/div[1]//a[1]")
subst = "'"
result = regex.sub(subst, test_str)
if result:
print(result)