const regex = /[\\~]+'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\\~]+\'', 'g')
const str = `//window[2]//header[@id=\\'top\\']/div[1]//a[1]
//window[2]//header[@id=\\\\'top\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\'top\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\'top\\\\\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\\\\\\'top\\\\\\\\\\']/div[1]//a[1]
(OR)
//window[2]//header[@id=~~~~~'top~~~~~']/div[1]//a[1]`;
const subst = `'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);