import Foundation
let pattern = #"[\\~]+'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
//window[2]//header[@id=\'top\']/div[1]//a[1]
//window[2]//header[@id=\\'top\\']/div[1]//a[1]
//window[2]//header[@id=\\\'top\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\'top\\\\']/div[1]//a[1]
//window[2]//header[@id=\\\\\'top\\\\\']/div[1]//a[1]
(OR)
//window[2]//header[@id=~~~~~'top~~~~~']/div[1]//a[1]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)