# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\p{L}\s]*\p{L})\p{L}*/$1/gu;t' <<< "Aliquam ipsum ex, tempus ornare semper ac, varius vitae nibh.
Dumnezeu a zis: „Să fie o întindere între ape, și ea să despartă apele de ape"